Wednesday, June 28, 2006

Y!oogle


YM Google
Originally uploaded by Anthroponym.
Installed YM 8. And it had an annoying ebay ad. So I got hold of a registry hack that was supposed to remove the ad from the main window.
Now the hack said i need to put a '*', but i put a * followed by a space and restarted YM.
What do I see? In place of an ebay ad, I see a Google page. With a * in the search box. Now I can enter a search query and hit 'Enter' to trigger a google search too, and view the results in the same small rectangular area. The display was all jumbed up though.
And Google is not even my browser home page. :-o
Hmmm... interesting.

Update 1: While Google is not my homepage, it is the default search engine on IE.

Update 2:It seems YM uses IE to render the ad. And the URL i put in the registry was mangled. In IE, bad URLs become searches and a Google search was done.
So it doesn't seem to be some easter egg on YM.

5 comments:

Sundar said...

Is Google your default search engine in your browser?

Anthroponym said...

On IE? Yes. Not on FF. Since on FF i use the search box on the right top corner.

Sundar said...

YM might be using IE defaults.

Sundar said...

Yahoo! Messenger perhaps uses IE as the engine to render the ad and you'd mangled the URL in the registry hack. In IE bad urls become searches. Since Google is your default search engine, you've got the search results page instead of an ad. Nothing wrong with YM. ;)

Ambar said...

yep. YM does seem to use IE engine for ad-rendering, among other things. It even uses IE's proxy settings.